SHC Installation mit Stretch

  • Installation

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • SHC Installation mit Stretch

    Hallo
    Versuche gerade SHC auf einen neu aufgesetzten RPi2b mit Stretch
    zu installieren.

    Bei "~ $ sudo apt-get install php5-common php5-cgi php5-cli php-apc"

    erscheint
    Paket php-apc ist nicht verfügbar, wird aber von einem anderen Paket
    referenziert. Das kann heißen, dass das Paket fehlt, dass es abgelöst
    wurde oder nur aus einer anderen Quelle verfügbar ist.

    Habe darauf weiter installiert und es erscheint bei "/var/www/shc $ php install.php"
    kein soll SHC, soll PCC installiert werden.
    "Die Datenbank wurde erfolgreich erstellt" wird angezeigt.
    Kann besser Hardware als Software !
  • premo schrieb:

    Habe darauf weiter installiert und es erscheint bei "/var/www/shc $ php install.php"kein soll SHC, soll PCC installiert werden.
    "Die Datenbank wurde erfolgreich erstellt" wird angezeigt.
    Aber ab hier komme ich nicht weiter.
    Es erscheint kein soll SHC/PCC installiert werden.
    Nur der grüne Hinweis
    Die Datenbank wurde erfolgreich erstellt.
    Kann besser Hardware als Software !
  • agent47 schrieb:

    php-apc kannst du auch weg lassen, das ist nur ein cache


    Habe es mal weggelassen aber ab "sudo apt-get install php5-redis "
    kommt der nächste Fehler.
    Scheint wohl an Stretch zu liegen. Mit Jessie läuft alles bestens.

    php5_redis.JPG

    Habe jetzt festgestellt dass genau an dieser Stelle auch 123.emil die gleichen Probleme hat.
    Siehe Beitrag #48
    SHC 2.2.7 Master / Slave auf Jessie von Grund auf installieren
    Kann besser Hardware als Software !

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von premo ()

  • Genau das ist es.
    Hab jetzt folgendes installiert.

    Quellcode

    1. PHP7 für Stretch
    2. PHP7 kann einfach mit folgenden Befehlen installiert werden.
    3. apt-get update
    4. apt-get install php7.0-common php7.0-fpm php7.0-cli php7.0-json php7.0-mysql php7.0-curl php7.0-intl php7.0-mcrypt php-pear php7.0-gd php7.0-zip php7.0-xml php7.0-mbstring
    dann den Befehl auf "~ $ sudo apt-get install php7.0-redis" geändert.
    Danach ging es mit "soll SHC/PCC" weiter.

    Jetzt aber komme ich mit "http://IP/shc?app=shc" nicht auf die Weboberfläche.
    Es erscheint nue eine weisse Seite.
    Kann besser Hardware als Software !
  • Bin jetzt mit diesem Installationsweg auf die GUI gekommen.

    Quellcode

    1. ~ $ sudo apt-get update
    2. ~ $ sudo apt-get upgrade -y
    3. ~ $ sudo apt-get install git-core
    4. ~ $ sudo apt-get install php7.0-common php7.0-cpi php7.0-cli php7.0-apcu
    5. ~ $ sudo apt-get install apache2 libapache2-mod-php7.0
    6. sudo nano /etc/apache2/sites-available/000-default.conf ---->/html entfernen
    7. sudo service apache2 restart
    8. ~ $ sudo apt-get install redis-server
    9. ~ $ sudo apt-get install php7.0-redis
    10. SHC und PCC Installation ----> wie gehabt
    11. Ramdisk konfiguriert
    12. Zugriff auf "http://IP-RPI/shc?app=shc" OK
    13. Anmeldung und Zugriff bis auf Serverstatus OK
    14. Bei Zugriff auf Serverstatus erscheint wieder die "weisse GUI Seite".
    Alles anzeigen
    Auch kann der Sheduler oder Schaltserver nicht konfiguriert werden.
    Bei Eingabe von "php index.php app=shc -sh -c" erscheint wieder "pi@raspberrypi:/var/www/shc $"
    Kann besser Hardware als Software !

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von premo ()

  • premo schrieb:

    Auch kann der Sheduler oder Schaltserver nicht konfiguriert werden.
    Bei Eingabe von "php index.php app=shc -sh -c" erscheint wieder "pi@raspberrypi:/var/www/shc $"
    Habe nochmal den RPi mit Stretch neu aufgesetzt und SHC nach html installiert.
    Kann jetzt den Sh und Ss konfigurieren.
    Jetzt erscheint aber ein PHP Fehler nach öffnen des Serverstatus.
    php Fehler.JPG
    Kann besser Hardware als Software !
  • ich habe das gleiche Problem. Ich habe jetzt 2 mal installiert.
    Installation funktioniert mit php7. Die Installation mit install.php läuft durch und verbindet korrekt mit Redis.
    Die Weboberfläche kann ich ohne Fehler aufrufen und mich anmelden (der Serverstatus liefert nur HTTP Error 500), aber damit könnte ich ggf. noch leben.
    Nur "php index.php app=shc -sh -c" bzw. -ss kehr meldungslos zur Shell zurück. Keine Fehlermeldung oder sonstiges, nichts. (im /var/log/ finde ich auch nichts) Kann man irgendwie ein php-log aktivieren?

    Ich habe generell mit dem Image von raspberrypi.org aufgesetzt, dann erst mal raspi-config, apg-get update & upgrade.
    Dann php7.0 und redis installiert mir von github das SHC_Framework geholt.
    (welches Version liegt jetzt eigentlich offiziell bei github? 2.2.7 oder 2.2.8)
    Auch habe ich die java-jre noch installiert (braucht man die überhaupt für die 2.2.8 schon?)

    Ergebnis bleibt gleich. Sheduler und co. lassen sich nicht konfigurieren oder starten.
    Gruß Dieter
    --------------
    Alle sagten: "Das geht nicht.". Dann kam einer, der wusste das nicht, und hat's einfach gemacht.
  • Habs nochmal probiert. Bin ein Stück weiter gekommen.
    Konnte den Ss und Sh jetzt einrichten.
    Jetzt erscheint aber eine PHP Warnung.

    Quellcode

    1. sudo apt-get install git-core
    2. sudo apt-get install php7.0-common php7.0-fpm php7.0-cli php7.0-cgi php7.0-json php7.0-mysql php7.0-curl php7.0-intl php7.0-mcrypt php-pear php7.0-gd php7.0-zip php7.0-xml php7.0-mbstring -y
    3. sudo apt-get install apache2 libapache2-mod-php7.0
    4. sudo nano /etc/apache2/sites-available/000-default.conf
    5. /var/www (/html) -----> Entfernen
    6. Autostart einrichten für Stretch einrichten!
    7. sudo apt-get install redis-server
    8. sudo apt-get install php7.0-redis
    9. sudo reboot
    10. cd /var/www
    11. sudo git clone https://github.com/agent4788/SHC_Framework
    12. sudo mv SHC_Framework/ shc/
    13. cd shc/
    14. sudo chmod 0777 -R ./
    15. php install.php
    16. soll SHC= ja
    17. soll PCC= ja
    18. sudo chmod 0777 -R ./
    Alles anzeigen
    Dateien
    • php warnung.JPG

      (119,84 kB, 12 mal heruntergeladen, zuletzt: )
    Kann besser Hardware als Software !
  • Mal abgesehen davon, dass ich nur php7.0-common, -cli, -cgi, -apcu und libapache2-mod-php7.0 (nur mit php7 findet er nicht) installiert habe, kann ich zwar die Oberfläche starten, aber eben nicht die Dienste konfigurieren.
    Ich habe 2 mal komplett Stretch neu auf die SD gemacht.
    Da ich so nicht weiter komme, bleibt mir nur der Weg zurück auf Jessie. Was ich jetzt auch mit letzten aktuellen Jessie gemacht habe.

    An deiner Meldung finde ich folgendes interessant:
    Der Hinweis auf die fehlerhafte /boot/config.txt.
    Was steht denn bei Stretch in Zeile 5 der config.txt?
    Gruß Dieter
    --------------
    Alle sagten: "Das geht nicht.". Dann kam einer, der wusste das nicht, und hat's einfach gemacht.
  • DieterWo schrieb:

    Mal abgesehen davon, dass ich nur php7.0-common, -cli, -cgi, -apcu und libapache2-mod-php7.0
    Damit konnte ich ebenfalls die Dienste nicht konfigurieren.
    Nach suchen im Net hatte ich diesen Befehl gefunden und danach
    konnte man die Dienste konfigurieren.
    Mit dieser Anleitung wurden jetzt schon 3 RPi (A, 2B+, und 3) erfolgreich
    bis auf PCC installiert.

    In Zeile 5 der config.txt steht
    # uncomment if you get no picture on HDMI for a default "safe" mode
    Kann besser Hardware als Software !
  • premo schrieb:

    DieterWo schrieb:

    Mal abgesehen davon, dass ich nur php7.0-common, -cli, -cgi, -apcu und libapache2-mod-php7.0
    Damit konnte ich ebenfalls die Dienste nicht konfigurieren.Nach suchen im Net hatte ich diesen Befehl gefunden und danach
    konnte man die Dienste konfigurieren.
    Mit dieser Anleitung wurden jetzt schon 3 RPi (A, 2B+, und 3) erfolgreich
    bis auf PCC installiert.
    Ah..mag natürlich sein, dass evtl. die eine oder andere PHP-Funktion in ein anderes Paket gewandert ist. Das werde ich noch mal ausprobieren, wenn Zeit ist.


    premo schrieb:

    In Zeile 5 der config.txt steht
    # uncomment if you get no picture on HDMI for a default "safe" mode
    in der Datei /www/var/shc/rwf/lib/runtime/raspberrypi.class.php in Zeile 91 wird mittel der PHP-Funktion parse_ini_file der Inhalt der config.txt geparst (vermutlich um overclocking auszulesen o. ä. ).
    Dabei tritt der fehler auf. Du könntest ja mal testweise diese Zeile auskommentieren. Letztlich wird das eh nur für das CPI-Info benötigt.

    Dann könnte man die config.txt mal untersuchen, ob mit Stretch dort vielleicht eine Syntaxverletzung eingebaut wurde, so dass parse_ini_file eine Exception auslöst.
    Dann könnte man die config.txt mal auf die relevanten Zeilen kürzen, also einfach mal alle Kommentare rausschmeißen.

    Oder vielleicht als erstes nur die Zeile 5 aus der config.txt. Denn das ist die einzige Zeile, in der " verwendet wird. Ich denke da wird der Fehler liegen, und der parser kommt aus dem tritt.
    Gruß Dieter
    --------------
    Alle sagten: "Das geht nicht.". Dann kam einer, der wusste das nicht, und hat's einfach gemacht.
  • Hallo Premo,

    vielen Dank für Deine Beschreibung zur Installation von SHC auf die Strech Lite Version. Es hat alles sehr gut funktioniert. Da ich überwiegend intertechno Funkdosen besitze habe ich zusätzlich pilight installiert. Nach einem reboot habe ich folgende Meldung erhalten:

    No ssdp connection found

    Erst wenn ich folgende Schritte ausführe, kann ich mit SHC oder direkt mit pilight arbeiten.

    sudo service pilight stop
    sudo iptables -A INPUT -s 127.0.0.1 -j ACCEPT
    sudo service pilight start


    Diese Befehle habe ich in der /etc/rc.local mit aufgenommen und nach einem reboot schein alles zu gehen. Nun habe ich beobachtet, dass wenn eine Zeitlang keine Aktivitäten mit pilight erfolgen, muss kann ich auch keine Funkdosen mehr schalten. Erst wenn ich diese 3 Befehle wieder abarbeite funktioniert alles wieder. Daher meine Frage hast Du einen Tipp für mich?

    Ich nutze einen Raspi3 sowie das aktuelle Strech Lite (Stand 1.Dezember 2017) sowie pilight 8 und SHC 2.2.8. Ich bin mir sicher das es kein SHC Problem ist. Aber vieleicht hast Du eine Idee???

    Viele Grüße